Specifying -vm option in Eclipse

I recently had the trouble of having multiple Eclipse installs in the system. And since I didn’t have web connection then, the whole installation had to be done offline.

I was coding with Project Darkstar using the Darkstar Maven Plugin. I installed the M2Eclipse plugin for better mvn integration. When I restarted the ide, I got this wierd warning:
The Maven Integration requires that Eclipse be running in a JDK, because a number of Maven core plugins are using jars from the JDK.

Please make sure the -vm options in eclipse.ini is pointing to a JDK and verify that Installed JREs are also using JDK installs.

Wierd. I checked my Installed JREs (Windows>Preferences>Java>Installed JREs) and I was using a JDK. I checked my eclipse.ini and added on the first line:

-vm "C:Program Files (x86)Javajdk1.6.0_06bin"
Didn’t work, and so lacking net access, I proceeded to ignore the warning. My only problem was that the javadoc for jdk classes where lacking. And when you autocomplete method calls, parameters were replaced with “arg0, arg1.. “. No big deal. I could just manually locate the javadocs and point my jdk to them.
A while ago, I decided I had enough of the startup warning and took matters to the java forums. Turns out my -vm command in eclipse.ini was being silently ignored because apparently it wasn’t the right syntax. It should be:
-vm
C:Program Files (x86)Javajdk1.6.0_06bin

With the newline and without the quotes. Yup, one of those quirks worth posting a blog for.
Finally, I can start my Eclipse in peace.